Results 1 to 7 of 7
  1. #1
    06cs's Avatar
    06cs is offline Porsche Activist
    Join Date
    May 2008
    Posts
    304
    Images
    4
    Downloads
    15
    Uploads
    0

    p0117 code and engine problems

    just starting today on startup the engine revved to 2000rpm for 5-10 seconds (this is not mornal, engine has never gone that high on startup) and during the drive home i notice engine is in limp mode (cannot rev past 4K)

    no CEL either

    last time this happened it was a bad MAF and dealer replaced at a cost of
    $1000 (dealer is notorious for ripping customers off) so i am not wanting to go back to dealer

    so i plug in duramtetrics and it gives me code P0117 which is coolant temp sensor. however, my gauge shows coolant as normal (in the middle temp, not far left) , actual values shows -40c temp for coolant?

    any ideas? should i try order a new sensor and try replacing it myself? i read somewhere it's under the car and hard to get to? any thoughts other than "take it to the dealer" would be appreciated.

    thanks
    06 Carrara White S - SRP 4.1 / FVD Exhaust / Techart Springs / 19" Carrera Classics


  2. #2
    jaica's Avatar
    jaica is offline FAQ TEAM
    1,000 post club
    Join Date
    Apr 2006
    Location
    Puerto Rico
    Posts
    1,610
    Images
    15
    Downloads
    78
    Uploads
    0

    Re: p0117 code and engine problems

    Any independent Porsche mechanics in your area? Did you try erasing the code and it came back? Did you check your coolant reservoir to make sure it was full. WARNING check only when completely cool.
    Having fun in Puerto Rico

  3. #3
    06cs's Avatar
    06cs is offline Porsche Activist
    Join Date
    May 2008
    Posts
    304
    Images
    4
    Downloads
    15
    Uploads
    0

    Re: p0117 code and engine problems

    there is a lambo/lotus dealer that services porsche but their pricing isn't far off of the P dealer. i didn't try clearing the code yet because i don't think that will affect how my car drives. will check the coolant level tomorrow...
    06 Carrara White S - SRP 4.1 / FVD Exhaust / Techart Springs / 19" Carrera Classics

  4. #4
    Rockster is offline Porsche Idealist 500 post club
    Join Date
    Apr 2009
    Location
    Livermore, CA
    Posts
    799
    Downloads
    2
    Uploads
    0

    Re: p0117 code and engine problems

    Quote Originally Posted by 06cs View Post
    just starting today on startup the engine revved to 2000rpm for 5-10 seconds (this is not mornal, engine has never gone that high on startup) and during the drive home i notice engine is in limp mode (cannot rev past 4K)

    no CEL either

    last time this happened it was a bad MAF and dealer replaced at a cost of
    $1000 (dealer is notorious for ripping customers off) so i am not wanting to go back to dealer

    so i plug in duramtetrics and it gives me code P0117 which is coolant temp sensor. however, my gauge shows coolant as normal (in the middle temp, not far left) , actual values shows -40c temp for coolant?

    any ideas? should i try order a new sensor and try replacing it myself? i read somewhere it's under the car and hard to get to? any thoughts other than "take it to the dealer" would be appreciated.

    thanks
    Ignore the temp gage it is useless.

    Either there's a wiring/connector problem at the sensor or the sensor is bad. The coolant temp is -40C cause the sensor output has an offset of -40C (0 = -40C, 0xFF (hex) or 255 is 215C. The sensor is reading 0 which suggests the thing is kaput.

    (I have upon occasion caught the sensor reading the max. too, on my 02 Boxster.)

    Check the wiring/connector. You might try disconnecting the sensor from the harness then reconnecting it in the hopes the problem is a marginal contact and the disconnect/connect will renew the contact by removing the surface corrosion at the connector.

    If this doesn't help you can replace the sensor yourself of have it replaced. I have never replaced one so I don't know what is involved.

    Sincerely,

    Rockster.

  5. #5
    K-Man S's Avatar
    K-Man S is offline Admin & Founder

    Join Date
    Aug 2005
    Location
    Overland Park, Kansas, United States
    Posts
    30,498
    Images
    4460
    Downloads
    253
    Uploads
    118
    Blog Entries
    14
    My Classifieds
    Gamer IDs

    Gamertag: KenDude

    Re: p0117 code and engine problems

    See: P0117

    For help!

  6. #6
    marco bok is offline Newbie
    Join Date
    Jan 2013
    Location
    Italy
    Posts
    1
    Downloads
    0
    Uploads
    0

    Re: p0117 code and engine problems

    Hi all! i have the same problem with my Boxster '06 and asking the mechanic he se says me I have to change three temperature sensors for 600 Euros!!
    But i'm not sure the problem will solve!!
    So i ask you how you resolve the problem,


  7. #7
    K-Man S's Avatar
    K-Man S is offline Admin & Founder

    Join Date
    Aug 2005
    Location
    Overland Park, Kansas, United States
    Posts
    30,498
    Images
    4460
    Downloads
    253
    Uploads
    118
    Blog Entries
    14
    My Classifieds
    Gamer IDs

    Gamertag: KenDude

    Re: p0117 code and engine problems

    Quote Originally Posted by marco bok View Post
    Hi all! i have the same problem with my Boxster '06 and asking the mechanic he se says me I have to change three temperature sensors for 600 Euros!!
    But i'm not sure the problem will solve!!
    So i ask you how you resolve the problem,

    Marco,
    Welcome to the site. We cannot diagnose your problem remotely, but if it is a temperature sensor, it might be just one sensor, not 3. If you are mechanically inclined or can take your car to an independent mechanic it might cost you less to change the primary sensor first and see if that fixes the problem, if not, then perhaps you do need more than one sensor.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •