Planet-9 Porsche Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
This past weekend when I turned off ignition my car went dead. As if no power from battery. Key stuck in ignition no accesory lights etc. Then few minutes later car came back on. Anyone know what might have caused this?
 

·
Registered
Joined
·
3,618 Posts
WAG: bad ignition switch contacts?
 

·
Registered
Joined
·
5,482 Posts
Ripple in the space time continuum?
 

·
Registered
Joined
·
349 Posts
Did you perhaps drive through a dark tunnel with light at the end of it?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,841 Posts
A little info on what yr car you have would be helpful, but probably the battery giving up the ghost.
 
  • Like
Reactions: MidEngine-Fan

·
Registered
Joined
·
166 Posts
Discussion Starter #6
2010 CS and battery is fine. Car started with no issues once power came back. In researching sounds like ignition switches can cause this or moons gravitational forces. I'm going with ignition switch
 

·
Premium Member
Joined
·
438 Posts
Double check the tightness of your battery connections.
 

·
Premium Member
Joined
·
2,524 Posts
My WAG would be the same as MidEngine-Fan. Ignition switch.

I doubt it's a physical relay any more but Porsche used to have a dropping relay that cut power to everything when the starter was engaged other than things needed to start the car. Think it was marked as X power but memory is fuzzy. Probably done now with the CANBUS saying you all power down now, hear? A glitch in reading ignition switch position could cause this. If everything but the starter, fuel pump and DME didn't have power I'd guess it would seem like the car went dead.

Getting fault codes read would be a start. Might have recorded something useful. For electrical gremlins it's always a good starting place.

Though I guess a ripple in the space time continuum is also possible...
 

·
Registered
Joined
·
866 Posts
My guess... Its been 100 percent humidity and if you are in CA, your car was not diggin the crazy change in weather!
 

·
Registered
Joined
·
866 Posts
+1 what has been up with that!

It tried to rain at night but still was 84* so failed to do so....
Still raining here in Ventura county!
 

·
Registered
Joined
·
54 Posts
Reviving this thread. My car, an 08 997 is doing the same thing but does it almost every time I turn it off. Basically I turn off the ignition and you can tell that the car seems to cut all power. After this happens my window, for example, will stay slightly down and not raise when I close the door. To fix this I need to turn the ignition on and off.
 

·
Premium Member
Joined
·
2,524 Posts
Never heard back from the OP as to a solution so the original guesses would be the starting point with the ignition switch first. Only other thought than those listed already is whatever circuit does the retained power thing.
 
1 - 16 of 16 Posts
Top