Planet-9 Porsche Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
I am finding that when I put my top up one of the buttresses keeps popping out. Does anyone know an easy fix for this?
 

·
Registered
Joined
·
1,262 Posts
I would check for dirt and wear on both pieces. I've had this happen once but it was operator error, I hadn't pushed the buttress end into the body socket firmly enough to get the click.
 

·
Registered
Joined
·
344 Posts
I have had no problems with my Spyder, but I rarely put the top up. Previously there was a post by another Spyder owner who had one of the fasteners come undone at speed. The flapping piece resulted in damage to the body. It turned out that the fastener was defective.

I would certainly get it checked out.



williamr
 

·
Registered
Joined
·
132 Posts
Make sure that when inserting the buttress end into the body socket you get an audible click as well as confirming that the red indicator tab is recessed.
 

·
Registered
Joined
·
1,587 Posts
I notice that if my trunk is completely closed when i go to click in the butresses, it is much more difficult to get a good 'catch'. when putting my top up, i barely engage the front latch, leave the trunk cracked and insert the buttresses, fully close the front latch, and then push the trunk shut the last final bit. Never had an issue with a buttress popping loose as a result. maybe thy that if you are not doing it already?
 

·
Registered
Joined
·
132 Posts
Agree- the key is to take some of the stress off of the buttresses while engaging the snaps. I do the opposite: Pull up the top to the front windshield with the rear trunk cracked, engage the flaps, close the trunk, then engage the electric motor to lock everything down.
 
1 - 8 of 8 Posts
Top