Planet-9 Porsche Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1 (Edited)
Has an error code come up for bank 2 knock sensor. Ordered a Bosch one for $20 and finally got around to installation. When I felt under the intake manifold to see where the sensor is located, came across a loose wire. "This can't be good" was my first thought. Was able to feel further and locate the knock sensor, with no wires attached. Seems that a rodent found a nice location to have a snack.

Was able to feed the loose wire out to where I could work on the end. Pulled the knock sensor without having to remove any part of the intake, so was fairly easy. The wires were chewed off at the base of the sensor. Could not locate any quick connectors that fit the knock sensor, so improvised some spade connectors with some shrink wrap, and made a short extension for each wire. These were then soldered onto the existing wires, and shrink wrapped. Spent more time looking for the quick connector than doing the repair.

It was then fed back through to where it belongs, and installed. Codes cleared, and all good.

Moral of story. Check wiring before purchasing new sensors. I ended up installing the new one anyways, but could have saved some money by inspecting first.

Cheers,
Ken
269344
269345
269346
269347
 

·
Registered
Joined
·
993 Posts
Well done, good repair!

I am so glad I do not have a rodent problem in my garage here (SoCal). Those things can certainly cause a lot of damage.
 
1 - 2 of 2 Posts
Top