Planet-9 Porsche Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Little back ground. I currently have the Remus cat back with plenum and gt3 throttle installed. Car ran perfectly fine for a month or so then just cruising the CEL popped on. Didn't feel like seeing it on so just reset the battery and it worked for about a week. Came back on did the same thing. I was finally sick of it went to Auto Zone and came up with the code P2198 bank 2 sensor 1 signal stuck rich. Now I've looked and read a bunch of stuff only to confuse me more. First off will just replacing the sensor do the trick? Is there any other options? If not, which side and sensor do I need to buy? It looks like something I can attempt to do on my own. Any help is greatly appreciated as I'm fairly new to the Porsche world. Thanks
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Ok so I changed the 02 sensor which was bank 2 sensor 1 ( passenger side before cat ). The car worked fine for a couple days and today another CEL. WTF. Did the scan. This time no specific sensor came up. It just said 02 sensor stuck rich P2198. Any ideas? Is this something that would go away after a software upgrade? I've got the Remus exhaust, ipd plenum and throttle,evoms v-flow intake and de-snork? How can I get rid of it for good?
 

·
Registered
Joined
·
1 Posts
Ok so I changed the 02 sensor which was bank 2 sensor 1 ( passenger side before cat ). The car worked fine for a couple days and today another CEL. WTF. Did the scan. This time no specific sensor came up. It just said 02 sensor stuck rich P2198. Any ideas? Is this something that would go away after a software upgrade? I've got the Remus exhaust, ipd plenum and throttle,evoms v-flow intake and de-snork? How can I get rid of it for good?
I have an 08 Cayman and i got the bank 2 sensor 1 reading as well, i tried to see the link someone posted on this chain but it does not work, i want to make sure i buy the right part. Thank you!
 
1 - 4 of 4 Posts
Top