Planet-9 Porsche Forum banner
  • Hello Everyone! Let us know what you would spend a $50 Amazon gift card on, HERE For a chance to win a $50 Amazon Gift Card!
1 - 20 of 33 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I did a oil change about 6mo ago and the oil level was one bar from the top. Now I'm getting an overfill warning saying unsafe to drive. I pull over and the level goes back down then I drive and the warning goes on again. Also I have an unusual amount of exhaust soot around the tailpipes. I am wondering if anyone had anything like this happen to their car? The car sounds and drives fine from what I can tell.
 

·
Registered
Joined
·
2,421 Posts
Do you drive mostly short trips? How many quarts did you put when oil was changed? Each segment is approx 0.45-qt, therefore, if your oil level showed full (just the top 'overfilled' segment not lit), that means that you could have, in theory, 0.01-qt or 0.45-qt in that segment. My guess is you were pretty close to full, meaning near 0.45-qt on that segment. If you only use your car on short trips, the condensation accumulation on your oil would rise its level, triggering an overfilled warning. You definitely DO NOT have an overfilled sump because you've been driving like that for months. It's either what I'm saying, or an oil sensor issue, which I doubt since you've done nothing to your car since the oil change. My suggestion is to first open the hatch, to clear the present reading. Then go for a long ride, of at least 20 miles (I'd do 25). Then park in your level garage with the engine idling, open the hatch again, close it, grab a watch with a second hand (your chrono -if equipped- would be perfect), make sure TFT is in the oil and coolant temp mode, shut the engine off, wait exactly ONE MINUTE, then turn ignition on, push TFT lever forward to get into car settings, choose oil measurement, and push forward again. That should give you the true reading of your oil level. Report back and we go from there. Good luck.
 

·
Registered
Joined
·
2,022 Posts
Do you drive mostly short trips? How many quarts did you put when oil was changed? Each segment is approx 0.45-qt, therefore, if your oil level showed full (just the top 'overfilled' segment not lit), that means that you could have, in theory, 0.01-qt or 0.45-qt in that segment. My guess is you were pretty close to full, meaning near 0.45-qt on that segment. If you only use your car on short trips, the condensation accumulation on your oil would rise its level, triggering an overfilled warning. You definitely DO NOT have an overfilled sump because you've been driving like that for months. It's either what I'm saying, or an oil sensor issue, which I doubt since you've done nothing to your car since the oil change. My suggestion is to first open the hatch, to clear the present reading. Then go for a long ride, of at least 20 miles (I'd do 25). Then park in your level garage with the engine idling, open the hatch again, close it, grab a watch with a second hand (your chrono -if equipped- would be perfect), make sure TFT is in the oil and coolant temp mode, shut the engine off, wait exactly ONE MINUTE, then turn ignition on, push TFT lever forward to get into car settings, choose oil measurement, and push forward again. That should give you the true reading of your oil level. Report back and we go from there. Good luck.
But this doesnt make sense Juan Carlos. I understand your "theory" that crossing the next to the top segment line if by anything at all could somehow trigger an overfill indicator, but 1) that assumes that the sensor actually works that way and doesnt require more than just 0.01 over the line to be read (that doesnt make sense as it would also assume you could be low on oil and still read full), and 2) that our engines somehow have that much water in the oil from condensation (thats a lot of water!). If actually true it seems that every single one of us would get the overfilled indicator at some point by following Porsche's instructions of filling the oil level up to the next to last bar.

My opinion is dont overthink it and follow the Porsche guidelines of checking the oil on a level surface when the engine is warmed up. If it says its overfilled, its overfilled. The OP didn't say if he had driven the car to circulate the oil and warm the engine up after the oil change when the "correct" reading was initially made or if he simply got that reading right after filling the car with oil after the change, which if true could explain the overfilling warning when driving.
 

·
Registered
Joined
·
1,920 Posts
It sounds strange for it to go up and down - especially if it is a lot. My off-the-cuff guess is that it is the level sensor or a temperature sensor and/or related wiring. The oil level sensor reading is adjusted by the oil temperature. I am not sure if this is done in software or it is built into the level sensor.

Take the oil filter housing off, drain 1/2 qt and see if the level still goes up and down. If it continues, it has to be electronic.

V6
 

·
Registered
Joined
·
4,848 Posts
It sounds strange for it to go up and down - especially if it is a lot. My off-the-cuff guess is that it is the level sensor or a temperature sensor and/or related wiring. The oil level sensor reading is adjusted by the oil temperature. I am not sure if this is done in software or it is built into the level sensor.

Take the oil filter housing off, drain 1/2 qt and see if the level still goes up and down. If it continues, it has to be electronic.

V6
Never had these problems when I used a dipstick. :)
 

·
Registered
Joined
·
779 Posts
[sarcasm]Well, that dipstick is soo heavy that Porsche had to remove it for acceleration and fuel economy! [/sarcasm]

V6
The dipstick, as you probably know, was removed for emission reasons -- crankcase fumes escaped from it.

As to the OP question -- probably the sensor if it is ok at some points and not at others and this is after six months. Assuming you never added any oil. Regardless, I'd go to the dealer or mechanic and have them look at the sensor.....
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #9 ·
Do you drive mostly short trips? How many quarts did you put when oil was changed? Each segment is approx 0.45-qt, therefore, if your oil level showed full (just the top 'overfilled' segment not lit), that means that you could have, in theory, 0.01-qt or 0.45-qt in that segment. My guess is you were pretty close to full, meaning near 0.45-qt on that segment. If you only use your car on short trips, the condensation accumulation on your oil would rise its level, triggering an overfilled warning. You definitely DO NOT have an overfilled sump because you've been driving like that for months. It's either what I'm saying, or an oil sensor issue, which I doubt since you've done nothing to your car since the oil change. My suggestion is to first open the hatch, to clear the present reading. Then go for a long ride, of at least 20 miles (I'd do 25). Then park in your level garage with the engine idling, open the hatch again, close it, grab a watch with a second hand (your chrono -if equipped- would be perfect), make sure TFT is in the oil and coolant temp mode, shut the engine off, wait exactly ONE MINUTE, then turn ignition on, push TFT lever forward to get into car settings, choose oil measurement, and push forward again. That should give you the true reading of your oil level. Report back and we go from there. Good luck.
I opened the hatch and drove for about 30 mins and oil came back to normal with fill level to one bar from the top. I don't trust that this won't happen again
 

·
Registered
Joined
·
2,022 Posts
I opened the hatch and drove for about 30 mins and oil came back to normal with fill level to one bar from the top. I don't trust that this won't happen again
You didn't give any details, but did you do the oil change yourself? If so, when you added the oil back did you simply fill the oil until you got to the last bar before driving it or did you run the engine adding the final oil slowly when warmed until you reached the correct level?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #11 ·
When I did oil change I put 7.9 quartz which brought me to one bar below full. I've never added any oil since. The oil only had about 2,000 miles on it and had been driving normal until this. While driving the overfill warning light came on. I immediately pulled over and turned off the car and checked inside the oil cap, all looked normal. I started the car back up and the oil level was normal for a few minutes after starting to drive again before it came back on. On a side note, there was a lot of soot on the exhaust which I've never seen before. That may or may not have anything to do with it.
 

·
Registered
Joined
·
2,022 Posts
When I did oil change I put 7.9 quartz which brought me to one bar below full. I've never added any oil since. The oil only had about 2,000 miles on it and had been driving normal until this. While driving the overfill warning light came on. I immediately pulled over and turned off the car and checked inside the oil cap, all looked normal. I started the car back up and the oil level was normal for a few minutes after starting to drive again before it came back on. On a side note, there was a lot of soot on the exhaust which I've never seen before. That may or may not have anything to do with it.
I cant explain why the issue would only appear 2,000 miles later, but the manual clearly states that the engine must be run and warmed up to temp before checking oil level. You cant just fill up to the next to last bar when its been sitting for any time and the fresh oil hasn't been circulated into the engine first (and you would have needed to wait at least an our hour to drain). As stated, mine shows one bar low after sitting for some time, but reads full once warmed up and checked per the manual procedure, so I'm assuming you overfilled the engine to begin with. This would possibly explain why it reads full after sitting but over filled when driven.

Im still having hard time understanding what exactly you mean by "one bar below full" as one bar below full is full based on the graph when the engine is warmed. It is not supposed to go all the way to the top like many people think. That is over filled, so forgive me if Im misunderstanding what you are saying. One bar below full to me means two bars down because the top bar is never filled
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #13 ·
When warmed up mine reads one bar below full also reads one bar below full when cold. I've never seen the bar move before. The 7.9 quarts was recommended from the manual.
 

·
Registered
Joined
·
2,022 Posts
Just to make sure we are all on the same page, this is full when the engine is hot. I cant explain why you are getting over fill warnings if this is where your oil level is when the engine is warm. I would have the dealer or you mechanic take a look if this is happening
 

Attachments

·
Registered
Joined
·
2,421 Posts
I opened the hatch and drove for about 30 mins and oil came back to normal with fill level to one bar from the top.
You're perfectly fine, just like I predicted. Remember it's an ELECTRONIC gauge. That means you're at the very top of your 4th segment, which is perfectly acceptable. But if you use your car for short trips, the extra condensation on your oil can trigger an overfill warning. On the plus side, that means your engine is consuming no oil, which is great news. You can waste your time with a dealer, or draining some oil, if you want. But once you understand you're dealing with an electronic sensor, your worries should ease. It's like checking a dipstick that shows right at the top limit, which is coincidentally where I always like to have my vehicles. By the way, I poured 9 qts on my car after letting it drain completely, and it also shows all 4 segments full. And finally, remember the correct way to check the oil level is as it's described in the manual, not when the car throws it. I pay no attention to that myself. If I want to check the oil level, I do it as I described (how the manual describes it as well). Enjoy your car man, Unless you have a real issue with the sensor, leave it alone. They're not prone to failure. But many owners are prone to not understand it correctly. He he. Take care.
 

·
Registered
Joined
·
258 Posts
I have found the oil sensor to be unreliable on one occasion. Long story, I won't repeat it all, but had a "Oil below minimum, do not drive" warning.
Added 2 quarts (I know, I know, should have only added one) and then I have "Oil above maximum, OK to drive" warning. Continued to drive 1000 miles on our trip, got home and drained 10 quarts out!
And no, it had nothing to do with condensation.
This was two years ago and 10,000 miles later and I have had no further problems. No oil consumption to speak of.
 

·
Registered
Joined
·
2,421 Posts
had a "Oil below minimum, do not drive" warning. And no, it had nothing to do with condensation.
Your first sentence made it obvious it had nothing to do with condensation;). Anyway, oil sensors rely on heat (the more the better) to work correctly. Sometimes in winter you can get erroneous info from the sensor, but again, I'd pay no attention to that, and do a manual check the way it should be done: flat surface, oil temp at least 200ºF, shut engine off, and check oil level a minute later. If you get an erroneous reading, then, and only then, you can suspect a defective sensor. I check oil level on my vehicles once a month, whether they have dipsticks or electronic sensors. That way you always know more or less where oil level should be. And if you happen to get a warning like yours, you'd know it's wrong.
 

·
Registered
Joined
·
258 Posts
Your first sentence made it obvious it had nothing to do with condensation;). Anyway, oil sensors rely on heat (the more the better) to work correctly. Sometimes in winter you can get erroneous info from the sensor, but again, I'd pay no attention to that, and do a manual check the way it should be done: flat surface, oil temp at least 200ºF, shut engine off, and check oil level a minute later. If you get an erroneous reading, then, and only then, you can suspect a defective sensor. I check oil level on my vehicles once a month, whether they have dipsticks or electronic sensors. That way you always know more or less where oil level should be. And if you happen to get a warning like yours, you'd know it's wrong.
Agree with comments. Some have suggested that I boiled off 2 quarts of water on the 350 mile trip to Vegas and then had the low warning. That did not add up because I was able to drain 10 quarts when I got home and I am very familiar with what an oil/coolant mix looks like and that is not what I drained. Also I drove 10-15 miles that morning, no incident. Then about 11 we headed out from the hotel and got the warning. BTW, had three green bars to start the trip. It had been that way since new.
 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top