Planet-9 Porsche Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter · #1 ·
I know the search is my friend, but I couldn't find these answers...

Yesterday I installed a PCM 2.1 in my Cayman. Worked GREAT. just plug and play. (bose & bose)

I'm getting the ERROR NO CD CHANGER message, no big deal. I understand that to be PIWIS-fixable.

When I do the MAIN-TRIP thing, I get the exclamation point also on the amp.
I guess the PCM was expecting a different amp?

Also, I am hearing a sound (like a disc trying to eject) every few minutes with the key off. I'm worried about it running my battery down. Ever heard of this?

Thanks!

Jim
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #3 ·
I found it on Craigslist for $750.00 plus shipping. Installed it myself. It's real easy, and there are some step by step instructions in the articles section.

Jim
 

·
Registered
Joined
·
674 Posts
Any updates with the eject noise? I'm also scared that my battery will drain


I know the search is my friend, but I couldn't find these answers...

Yesterday I installed a PCM 2.1 in my Cayman. Worked GREAT. just plug and play. (bose & bose)

I'm getting the ERROR NO CD CHANGER message, no big deal. I understand that to be PIWIS-fixable.

When I do the MAIN-TRIP thing, I get the exclamation point also on the amp.
I guess the PCM was expecting a different amp?

Also, I am hearing a sound (like a disc trying to eject) every few minutes with the key off. I'm worried about it running my battery down. Ever heard of this?

Thanks!

Jim
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top