Planet-9 Porsche Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
442 Posts
Discussion Starter #1
funnyly enough, i was on my way to the dealer to sort out some other problem when this happend.

the dealer just reset the computer, and said its more or less a signal hickup due to the coldness.

which sounded lame to me at the time, but i searched here which seemed to indicate; indeed this is the case.

anyone else who's experienced this which turned out to be serious ?
 

·
Registered
Joined
·
75 Posts
funnyly enough, i was on my way to the dealer to sort out some other problem when this happend.

the dealer just reset the computer, and said its more or less a signal hickup due to the coldness.

which sounded lame to me at the time, but i searched here which seemed to indicate; indeed this is the case.

anyone else who's experienced this which turned out to be serious ?
I had the exact same thing happen to my Cayman on two separate occasions. Both times, restarting the car cleared up the error codes. Both times, it was very cold and the ABS light came on when I braked hard on a somewhat icy road, immediately followed by the PSM light. My dealer said something similar to your dealer and no services were needed.
 

·
Registered
Joined
·
160 Posts
I am from the north and very use to cold places....this winter is has had extensive cold periods....in my opinion cold weather should affect braking/ABS systems...the PCM is another story....but my issues were finally resolved by having the dealer load the latest software/firmware, clean out the memories in the various control units and doing a clean install of the latest software....all my flakiness went away...knock on wood that it stays away. Another possibility on the ABS side is if ice/snow got on the wheel sensors....particularly if they were old...I have seen that on a few of my cars....but never ABS lights coming on just because its cold outside....
 

·
Registered
Joined
·
143 Posts
I just experienced the same thing this evening at the airport. In addition to the PSM and ABS Failure messages, the airbag light came on and System Fault Airbag message came on. I find it hard to believe that it is temperature related as it's 50 degrees and I drove the car in much colder weather. Will be dropping off at the dealer tomorrow morning.

Has anyone else had the airbag message come on at the same time as the other failure messages?
 

·
Registered
Joined
·
22 Posts
First time I had it the dealer reset it but it came back and needed a new ABS sensor ( not expensive )

it happened once again after I got stuck in snow but that cleared itself
 

·
Registered
Joined
·
4 Posts
For the first time, my Cayman S's PSM failure and ABS failure both lit up on 26May2010. My car was last serviced in Oct 2009 when I had changed all brakepads.

The car was in the sun for around 2 hours around 33C heat when I had it parked in an uncovered carpark. When I started the car both lights came on all the way for 30 mins until I reached home. I took out the key from the ignition, reinserted the key and restarted the car and no lights came on. The following day I drove the car again and no lights came on.

Should I take it to the dealer for check up now ? My next service is due in Oct 2010. Is it safe to drive ? It is unlikely that my brakes need attention as they are new brakes only 7 months old and I had only done 1000km since changing them. Any advice ?
 

·
Registered
Joined
·
19 Posts
funnyly enough, i was on my way to the dealer to sort out some other problem when this happend.

the dealer just reset the computer, and said its more or less a signal hickup due to the coldness.

which sounded lame to me at the time, but i searched here which seemed to indicate; indeed this is the case.

anyone else who's experienced this which turned out to be serious ?
Had this happen once in my '08 987. Was braking hard on a steep downgrade and the abs did pulse a couple times first. Was very disconcerting at the time, but that was about 2 years and 18000 miles ago. Obviously an aberration.
 

·
Registered
Joined
·
526 Posts
This happened to me about 2 weeks after getting my used 2008 CS. My independent diagnosed it as a brake pedal switch that was starting to fail. Same issues with abs and psm going off and clearing with a restart.
I got the brake pedal switch and after changing it I have not seen the warnings again.
Might not be the same issue but that is what mine was doing and what fixed it.
The brake pedal switch was under $20 fwiw
 

·
Registered
Joined
·
307 Posts
You may be able to attribute the loss of ABS, PSM, and even Homelink and heated seats to a weak battery that could be made worse by the cold. I let my battery run too low during the winter and have since charged it back to full power. However, the items above are going out intermittently (Homelink and heated seats totally dead) so it's clear I need to take the car to the dealer for some sort of code reset.
 

·
Registered
Joined
·
1 Posts
I had the ABS PSM error for years intermittently, and finally replaced the brake light sensor with one I got on Amazon for $8. Found the replacement instruction video on YouTube. 5 minute install, and the problem is solved!
 
1 - 16 of 16 Posts
Top