Planet-9 Porsche Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
976 Posts
Discussion Starter · #1 · (Edited)
So for some reason my clear side marker isn't working anymore and I have been getting the Warning "Left side market not working" on my display. I've had the car for 2 years and only 11700 miles so I'm surprised it went out so fast.

Tonight I tried disconnecting and reconnecting the side marker connection and it still doesn't shine. The problem is when I put it back it is very loose and will come out while driving.



Anyone know what I did wrong? It just doesn't "pop" in place.

I will have to reorder another set of clear side markers, has anyone else had their bulb burn out on them?

EDIT: found this picture, I definitely bent the metal piece..it isn't squared off like this one
 

· Registered
Joined
·
976 Posts
Discussion Starter · #2 ·
Question, are the orange side marker bulbs the same bulb used in the clear side marker or are they color coated?

Rather than buying another set of clear side markers, do you guys have any alternative bulbs you can recommend me? LED alternatives?
 

· Registered
Joined
·
976 Posts
Discussion Starter · #6 ·
Thanks guys.

Question, when your bulbs when out did you get a warning light in the dash saying "Check Left/Right Side Marker" ?

Is the warning system designed to know the bulb went out or could it be that the entire wiring on the left side marker went out due to water damage? Because I remember the light went off and on a few times before permanently.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top