Planet-9 Porsche Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter · #1 ·
I didn’t want hijack the ‘Why must go turbo’ thread so I’m starting a new one. HassaanAbdeen brought up he thinks there may be something wrong with my TCP stage III kit. HassaanAbdeen maybe you elaborate as to why you think that and what you think I should get checked. I’d really like to know your opinion as well as others. Like I said I worked in the industry for a short time in college, sort of an internship with a tuning company. The kit has a few bugs but I think they are minor issues that once worked out won’t really change the overall experience. So here is my experience with car.
From a stop through about 3k I get good smooth acceleration. About 3k I can start to feel the turbo start to pull. About 3.7k to 4K it plants me in my seat all the way to redline. Mostly it feels normal for an aftermarket tuned turbo car.

Now the issues are
I think the ramp up could be smoother from when the turbo starts to spool up to full boost.
It takes longer than I would expect for the boost to come back after a shift. I can mitigate this by holding throttle during a shift but still doesn’t feel quite rite if I don’t.
The car needs more bottom end to match the top end.

The last issue, the bottom end, I think is just inherent to this type of set up. The first two I think could be improved, not having Cayman or TPC experience I don’t know how much they could be improved. Changes that I can make before taking to TPC are playing with the Gready boost controller and the boost sense line is coming off the waste gate and I think it should be coming off the intake manifold to start.
So my questions for HassaanAbdeen and anyone else knowledgeable who is willing to chime in, is this similar to others experience? Are my issues just me being anal? Can these Issues be worked out by playing with the boost controller and fine tuning the system? Or do you think the kit has a real problem? Like I mentioned in the other thread turbos systems can be designed to have wildly different outcomes so without knowing what it is supposed to be like there is no way for me to know if mine is normal.

Thanks!:cheers:
 

·
Registered
Joined
·
285 Posts
Discussion Starter · #2 ·
another issue I forgot to mention that I think is the boost controller settings

It will dump all boost on hard pull if I let off the throttle a touch. example, if I'm getting on the freeway and winding it out in 3rd if I let off the gas a touch it looses all power, I think it may be a sensitivity setting in the boost controller but haven't had a chance to play with it yet.
 

·
Premium Member
Joined
·
6,730 Posts
Dear Fingers, I'd be more than happy to help but since TPC is more knowledgable about their own kit I forwarded this thread to Harris Lavitas for him to elaborate on this thread and assist you.

I'll keep an eye on this thread to make sure your issues are addressed and hopefully resolved.
 
  • Like
Reactions: pmonkey

·
Premium Member
Joined
·
579 Posts
I didn’t want hijack the ‘Why must go turbo’ thread so I’m starting a new one. HassaanAbdeen brought up he thinks there may be something wrong with my TCP stage III kit. HassaanAbdeen maybe you elaborate as to why you think that and what you think I should get checked. I’d really like to know your opinion as well as others. Like I said I worked in the industry for a short time in college, sort of an internship with a tuning company. The kit has a few bugs but I think they are minor issues that once worked out won’t really change the overall experience. So here is my experience with car.
From a stop through about 3k I get good smooth acceleration. About 3k I can start to feel the turbo start to pull. About 3.7k to 4K it plants me in my seat all the way to redline. Mostly it feels normal for an aftermarket tuned turbo car.

Now the issues are
I think the ramp up could be smoother from when the turbo starts to spool up to full boost.
It takes longer than I would expect for the boost to come back after a shift. I can mitigate this by holding throttle during a shift but still doesn’t feel quite rite if I don’t.
The car needs more bottom end to match the top end.

The last issue, the bottom end, I think is just inherent to this type of set up. The first two I think could be improved, not having Cayman or TPC experience I don’t know how much they could be improved. Changes that I can make before taking to TPC are playing with the Gready boost controller and the boost sense line is coming off the waste gate and I think it should be coming off the intake manifold to start.
So my questions for HassaanAbdeen and anyone else knowledgeable who is willing to chime in, is this similar to others experience? Are my issues just me being anal? Can these Issues be worked out by playing with the boost controller and fine tuning the system? Or do you think the kit has a real problem? Like I mentioned in the other thread turbos systems can be designed to have wildly different outcomes so without knowing what it is supposed to be like there is no way for me to know if mine is normal.

Thanks!:cheers:
Please call us or email us at [email protected] and on Monday when we are in the office, we will help you troubleshoot the car. It is easier to troubleshoot over the phone or by email than internet forums as we are pulled in many different directions during the work day. The cars run very smooth, so we would like to help you and figure out what is going on by logging data.
 
1 - 4 of 4 Posts
Top