Planet-9 Porsche Forum banner

6181 - 6200 of 6214 Posts

·
Registered
Joined
·
978 Posts
Removed the original air filters at 38k KMs. I'll be replacing them with BMCs in several weeks and had the time to pull them out. I have to say that they were a little dirtier than I was expecting, but then I guess these engines breathe a lot of air.

272012
 

·
Registered
Joined
·
477 Posts
Replaced Goodyears with Michelin Pilot Sport 4s. MUCH better ride IMO. Alignment and oil change. Car feels great. I'm at 21k miles total
 
  • Like
Reactions: bigmoguls

·
Registered
Joined
·
1,773 Posts
I really like this. How was the install?
Pretty straightforward, but I had already had some experience removing and replacing the aluminum trim pieces.

The hardest part was removing the shift handle, where it was necessary to use pliers on the locking collar (and tape to protect the finish). I had to use the pliers again for reinstallation. There wasn't a lot of room for leverage with fingers alone.
 

·
Registered
Joined
·
37 Posts
Installed a Maxspeed backup camera. Installation was smooth and everything worked.
Reminded me of installing Pioneer Supertuners and Jensen 6" x 9" coaxial speakers in the cars of my youth.
 

·
Registered
Joined
·
978 Posts
I just finished my Winter upgrades. BMC filters and full valved exhaust with 200 cell cats. I’m just waiting on the relevant tune so I can apply that. I’ve also just replaced my factory F1s with Michelin Pilot Sport 4s.

Now I just need to wait for better weather so I can try it all out!
 

·
Registered
Joined
·
20 Posts
Finally installed the Soul Performance Competition Headers I bought from another owner and updated to the Cobb Stage 2 93 Octane tune. While I had the exhaust manifolds out, I went ahead and replaced all 6 coil packs and plugs since access was unrestricted.

When I first fired it up, it was running horribly and throwing tons of codes. Threw the code reader on it and found misfires on cylinders 1 and 2. Pulled that tire to check things out and it turned out that I'd not quite reconnected those coilpacks all the way. Each was only maybe 1/16" from fully plugged in, but that was enough to cause problems. Pushed those all together fully, cleared the codes, and it started and ran smoothly. Just to be safe running the catless headers, I did use the Vibrant O2 sensor spacers with the smallest orifices, and it's running fine with no CEL.

Idle and normal driving around you can't really tell a difference, but at WOT it comes alive and screams now! Should be even more fun on track days now.
 

·
Registered
Joined
·
1,508 Posts
Great idea on changing plugs/coils while you had the headers out of the way. The off the shelf Cobb tunes are pretty weak, so consider getting yourself a custom remote pro tune via email using data logs provided by your Cobb device to really wake her up!
 
6181 - 6200 of 6214 Posts
Top