Planet-9 Porsche Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
Hey,

After I had the hole in the rotor in the back wheel I decided to play it safe and change the front and rear break discs and pads as well.
Everything is OEM and installed by Porsche but now I have a slight 'whistle' type of sound after the change of the breaks.
This being Thailand, the clocks are ticking a bit different and I was told his was normal... and would go away after a while. It's been a week and the sound is still there.. It occurs when breaking or when going really slow you can hear a whistle sound every 2 seconds or so.

Having owned several other sports cars including Lamborghini/Ferrari this sounds like total bull to me. Can anyone confirm that this is not normal and should be properly checked again?

On a side note, they showed me all the OEM parts from the install with before/after pictures. So the parts are all in fact brand new and OEM.
 

·
Registered
Joined
·
1,392 Posts
It sounds a bit like brake pad squeal. Have you bedded in the new brakes yet? If not, then do a few medium speed slow downs and allow the brakes to cool and then do a few high speed slow downs. Don't bring the car to a complete standstill and leave the hand brake off until everything has cooled down. If its still doing it after that, get a second opinion so that you have an argument to take back to the shop that fitted them.
 

·
Registered
Joined
·
124 Posts
Discussion Starter #3
It sounds a bit like brake pad squeal. Have you bedded in the new brakes yet? If not, then do a few medium speed slow downs and allow the brakes to cool and then do a few high speed slow downs. Don't bring the car to a complete standstill and leave the hand brake off until everything has cooled down. If its still doing it after that, get a second opinion so that you have an argument to take back to the shop that fitted them.
Thanks for your input! It's really getting weird. Just went grocery shopping - no sound on the way there. Drove back home and the noise was there again.
Maybe i need to take the car for a hundred miles on the express way to 'break it' in?!
 
1 - 3 of 3 Posts
Top